const regex = /<a[^>]*herf=''[^>]*>(.*?)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]*herf=\'\'[^>]*>(.*?)<\\\/a>', 'g')
const str = `this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);