import re
regex = re.compile(r"<a[^>]*herf=''[^>]*>(.*?)<\/a>")
test_str = "this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)