// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a[^>]*herf=''[^>]*>(.*?)<\/a>").unwrap();
let string = "this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}