# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d{1,2}(\.\d{2})?$/\1_XXX/gm;t' <<< "10
5
5.00
10.00
.25
10.1
10.255"