// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,2}(\.\d{2})?$").unwrap();
let string = "10
5
5.00
10.00
.25
10.1
10.255";
let substitution = "\\1_XXX";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}