import Foundation
let pattern = #"^\d{1,2}(\.\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10
5
5.00
10.00
.25
10.1
10.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_XXX"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)