package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}(\.\d{2})?$`)
var str = `10
5
5.00
10.00
.25
10.1
10.255`
var substitution = "\1_XXX"
fmt.Println(re.ReplaceAllString(str, substitution))
}