import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2}(\\.\\d{2})?$";
final String string = "10\n"
+ "5\n"
+ "5.00\n"
+ "10.00\n\n"
+ ".25\n"
+ "10.1\n"
+ "10.255";
final String subst = "\\1_XXX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}