re = /^\d{1,2}(\.\d{2})?$/m
str = '10
5
5.00
10.00
.25
10.1
10.255'
subst = '\\1_XXX'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result