#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d{1,2}(\.\d{2})?$"
Local $sString = "10" & @CRLF & _
"5" & @CRLF & _
"5.00" & @CRLF & _
"10.00" & @CRLF & _
"" & @CRLF & _
".25" & @CRLF & _
"10.1" & @CRLF & _
"10.255"
Local $sSubst = "\1_XXX"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)