using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?";
string input = @"function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}