import re
regex = re.compile(r".*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("function somefunc($param){\n"
"//begin_special\n"
"some code;\n\n"
"//some comments\n"
"//end_special\n"
"some code;\n"
"}")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")