package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im).*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?`)
var str = `function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}