const regex = /.*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?(\\\/\\\/begin_special([^\\x00]*?)\\\/\\\/end_special).*?', 'im')
const str = `function somefunc(\$param){
//begin_special
some code;
//some comments
//end_special
some code;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}