use strict;
my $str = 'function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}';
my $regex = qr/.*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?/imp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}