import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(\\/\\/begin_special([^\\x00]*?)\\/\\/end_special).*?";
final String string = "function somefunc($param){\n"
+ "//begin_special\n"
+ "some code;\n\n"
+ "//some comments\n"
+ "//end_special\n"
+ "some code;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}