$re = '/.*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?/im';
$str = 'function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);