#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^\p{Pd}]+)(\p{Pd})(.*)$"
Local $sString = "GBI - AVP SALES"
Local $sSubst = "$1-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)