re = /^([^\p{Pd}]+)(\p{Pd})(.*)$/m
str = 'GBI - AVP SALES'
subst = '$1-$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result