import re
regex = re.compile(r"^([^\p{Pd}]+)(\p{Pd})(.*)$", flags=re.MULTILINE)
test_str = "GBI - AVP SALES"
subst = "$1-$3"
result = regex.sub(subst, test_str)
if result:
print(result)