import Foundation
let pattern = #"^([^\p{Pd}]+)(\p{Pd})(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"GBI - AVP SALES"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)