using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\p{Pd}]+)(\p{Pd})(.*)$";
string substitution = @"$1-$3";
string input = @"GBI - AVP SALES";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}