$re = '/^([^\p{Pd}]+)(\p{Pd})(.*)$/m';
$str = 'GBI - AVP SALES';
$subst = "$1-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;