use strict;
my $str = 'GBI - AVP SALES';
my $regex = qr/^([^\p{Pd}]+)(\p{Pd})(.*)$/mp;
my $subst = '$1-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";