#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(")?(.*?)\1\s*(?:,|$)"
Local $sString = "name,age,booktitle" & @CRLF & _
"John,,Hello World" & @CRLF & _
"Mary,3,""Alas, What Can I do?""" & @CRLF & _
"Joseph,5,"Waiting, waiting, waiting"" & @CRLF & _
""Donaldson Jones" , six, "Hello, friend!""
Local $sSubst = "($2)\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)