re = /\s*(")?(.*?)\1\s*(?:,|$)/m
str = 'name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,"Waiting, waiting, waiting"
"Donaldson Jones" , six, "Hello, friend!"'
subst = '($2)\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result