import Foundation
let pattern = #"\s*(")?(.*?)\1\s*(?:,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,"Waiting, waiting, waiting"
"Donaldson Jones" , six, "Hello, friend!"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($2)\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)