import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\")?(.*?)\\1\\s*(?:,|$)";
final String string = "name,age,booktitle\n"
+ "John,,Hello World\n"
+ "Mary,3,\"\"Alas, What Can I do?\"\"\n"
+ "Joseph,5,\"Waiting, waiting, waiting\"\n"
+ "\"Donaldson Jones\" , six, \"Hello, friend!\"";
final String subst = "($2)\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}