$re = '/\s*(")?(.*?)\1\s*(?:,|$)/m';
$str = 'name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,"Waiting, waiting, waiting"
"Donaldson Jones" , six, "Hello, friend!"';
$subst = "($2)\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;