use strict;
my $str = 'name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,"Waiting, waiting, waiting"
"Donaldson Jones" , six, "Hello, friend!"';
my $regex = qr/\s*(")?(.*?)\1\s*(?:,|$)/mp;
my $subst = '($2)\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";