using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*("")?(.*?)\1\s*(?:,|$)";
string substitution = @"($2)\n";
string input = @"name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,""Waiting, waiting, waiting""
""Donaldson Jones"" , six, ""Hello, friend!""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}