#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$"
Local $sString = "C:\\33\\dd\\Desktop\\151222055438.txt" & @CRLF & _
"c:\\ff\\ded\\Desktop\\151222055438.txt" & @CRLF & _
"Z:\\ss\\gg\\Desktop\\151222055438.txt" & @CRLF & _
"d:\\da\\ds\\Df\\ff.txt" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3:\\rr\\555\\Desktop\\151222055438.txt" & @CRLF & _
"d\\33\\4\\Desktop\\151222055438.txt" & @CRLF & _
"s:\\\\rr\\d\\Desktop\\151222055438.txt" & @CRLF & _
"s:\\\\\\f\\f\\Desktop\\151222055438.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")