const regex = /^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]:(\\\\{2}[a-zA-Z0-9.]+)+$', 'mg')
const str = `C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt
c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt
Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt
d:\\\\da\\\\ds\\\\Df\\\\ff.txt
3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt
d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}