use strict;
my $str = 'C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt
c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt
Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt
d:\\\\da\\\\ds\\\\Df\\\\ff.txt
3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt
d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt';
my $regex = qr/^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}