package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$`)
var str = `C:\\33\\dd\\Desktop\\151222055438.txt
c:\\ff\\ded\\Desktop\\151222055438.txt
Z:\\ss\\gg\\Desktop\\151222055438.txt
d:\\da\\ds\\Df\\ff.txt
3:\\rr\\555\\Desktop\\151222055438.txt
d\\33\\4\\Desktop\\151222055438.txt
s:\\\\rr\\d\\Desktop\\151222055438.txt
s:\\\\\\f\\f\\Desktop\\151222055438.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}