# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$"
test_str = ("C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt\n"
"c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt\n"
"Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt\n"
"d:\\\\da\\\\ds\\\\Df\\\\ff.txt\n\n\n"
"3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt\n"
"d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt\n"
"s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt\n"
"s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.