$re = '/^[a-zA-Z]:(\\\\{2}[a-zA-Z0-9.]+)+$/m';
$str = 'C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt
c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt
Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt
d:\\\\da\\\\ds\\\\Df\\\\ff.txt
3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt
d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);