import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]:(\\\\{2}[a-zA-Z0-9.]+)+$";
final String string = "C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt\n"
+ "c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt\n"
+ "Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt\n"
+ "d:\\\\da\\\\ds\\\\Df\\\\ff.txt\n\n\n"
+ "3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt\n"
+ "d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt\n"
+ "s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt\n"
+ "s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}