using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$";
string input = @"C:\\33\\dd\\Desktop\\151222055438.txt
c:\\ff\\ded\\Desktop\\151222055438.txt
Z:\\ss\\gg\\Desktop\\151222055438.txt
d:\\da\\ds\\Df\\ff.txt
3:\\rr\\555\\Desktop\\151222055438.txt
d\\33\\4\\Desktop\\151222055438.txt
s:\\\\rr\\d\\Desktop\\151222055438.txt
s:\\\\\\f\\f\\Desktop\\151222055438.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}