// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$").unwrap();
let string = "C:\\\\33\\\\dd\\\\Desktop\\\\151222055438.txt
c:\\\\ff\\\\ded\\\\Desktop\\\\151222055438.txt
Z:\\\\ss\\\\gg\\\\Desktop\\\\151222055438.txt
d:\\\\da\\\\ds\\\\Df\\\\ff.txt
3:\\\\rr\\\\555\\\\Desktop\\\\151222055438.txt
d\\\\33\\\\4\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\rr\\\\d\\\\Desktop\\\\151222055438.txt
s:\\\\\\\\\\\\f\\\\f\\\\Desktop\\\\151222055438.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}