import Foundation
let pattern = #"^[a-zA-Z]:(\\{2}[a-zA-Z0-9.]+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\\33\\dd\\Desktop\\151222055438.txt
c:\\ff\\ded\\Desktop\\151222055438.txt
Z:\\ss\\gg\\Desktop\\151222055438.txt
d:\\da\\ds\\Df\\ff.txt
3:\\rr\\555\\Desktop\\151222055438.txt
d\\33\\4\\Desktop\\151222055438.txt
s:\\\\rr\\d\\Desktop\\151222055438.txt
s:\\\\\\f\\f\\Desktop\\151222055438.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)