# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)/TC_\3_\2_\4/;t' <<< "RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3"