package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)`)
var str = []byte(`RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3`)
var substitution = []byte("TC_\3_\2_\4")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}