const regex = new RegExp('(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)', '')
const str = `RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3`;
const subst = `TC_\3_\2_\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);