import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)";
final String string = "RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3";
final String subst = "TC_\\3_\\2_\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}