// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)").unwrap();
let string = "RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3";
let substitution = "TC_\\3_\\2_\\4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}