#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)"
Local $sString = "RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3"
Local $sSubst = "TC_\3_\2_\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)