import re
regex = re.compile(r"(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)")
test_str = "RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3"
subst = "TC_\\3_\\2_\\4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)