# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<(?P<end>\\/*)(A)(?P<number>\d+)>)(.*?)<\/\3\4>/<test number="\g<number>">\5<\/test>/s;t' <<< "<T1>
<A1>
lorem ipsum
</A1>
</T1>"