# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>"
test_str = ("<T1>\n"
" <A1>\n"
" lorem ipsum\n"
" </A1>\n"
" </T1>")
subst = "<test number=\"\\g<number>\">\\5</test>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.